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Using Acrobat to Make a PDF file Accessible

Level

Intermediate - Advanced. Students are assumed to have experience with the different features and
menu options of Adobe® Acrobat®. Students will be working primarily with Portable Document Format
(PDF) document accessibility preferences.

Summary and Objectives

The purpose of this lesson is to introduce the student to the use of Acrobat as a tool for making it easier
for vision and motion challenged users to access and manage information in PDF files. Section 508 of
the U.S. Rehabilitation Act requires federal departments and agencies that use electronic and
information technology to ensure that federal employees and members of the public with disabilities
have access to this information in an accessible format. PDF is one of these acceptable formats.

This lesson will specifically introduce: (1) using Acrobat to read a PDF file, (2) setting Acrobat
accessibility preferences, (3) enhancing visibility of a PDF file, and (4) checking and analyzing the
accessibility of PDF files..

At the end of this lesson students will be able to:

1. Set the Read-Out-Loud feature.

2. Set different reading preferences.

3. Change visual aspects of a PDF document.

4. Reduce keyboard and mouse interaction.

5. Verify the accessibility of a PDF document.

➤ Lesson thirteen is designed to be taught in a single one-hour session. The student will explore the preferences and
options for different accessibility features and be able to make PDF documents more accessible.

Key Terms for Lesson Thirteen

Screen Reader: An assistive technology application that enable visually impaired users to interact with
computer applications.

Unstructured PDF: All content is treated as a single unit without any hierarchies or relationships. Unstructured
PDF files retain the author’s text and paragraphs. All other formatting, including formatting for basic text, tables,
and lists, is lost.

Structured PDF: PDF files that have logical structure outlines that refer to the author’s content in a natural
reading order. This structure tree appears on the Tags tab in the navigation pane and shows elements nested at
various levels.

Tagged PDF: Documents that have a logical structure plus additional information that permits reflow. Tagged
files recognize tables, formatted lists, and tables of contents. Tagged files also recognize which content blocks
belong to the different stories and contain text-formatting information such as spacing between words.
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Exercise One: Investigating PDF Accessibility Features
Accessibility features are tools and resources that make it easier for vision- and motion-challenged users to
access information and controls for Adobe PDF documents. Several features in Acrobat address specific
accessibility issues:

•  Speech functionality, including support for utilities and devices that read visual elements, controls, and text,
and convert them into spoken language.

•  Visibility adjustments to make text and graphics easier to view for people with a limited range of vision.
•  Navigation through documents using auto-scroll, to reduce required keyboard and actions.
•  Keyboard alternatives to mouse actions.
•  Options for creating Adobe PDF files that make documents more reliably accessible.

About Reading Preferences

The Reading Preferences panel contains a list of the options that can be set for a particular PDF document. To
access these preferences choose Edit > Preferences and click on the Reading preference in the left pane.

You can use the Reading preferences to change the volume, speed, and order in which documents are read out
loud. If you experience difficulties reading a document with a screen reader, changing the reading order
preference options can sometimes help.

To view reading preferences do this:

1. Open the file Brochure.pdf from the Acrobat
Curriculum Guide Resources folder.

2. Choose Edit > Preferences and select Reading.

3. For Read Out Loud options, select the settings you
want for volume, voice, pitch, and words per
minute.

4. Select a Reading Order option and choose whether
to override the reading order in tagged documents.

5. For Screen Reader Options, select Deliver Data in
Pages When Document Exceeds, and then type a
number for the amount of pages to download
(default is 10 pages).

6. Click OK.
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Exercise Two:  Creating Accessible Documents
For this activity you will use the “Section 508 Facts” brochure located in the Acrobat Curriculum Guide Resources
folder. Though not an actual screen reader, the Read-Out-Loud feature makes it easy for PDF files to be read by
your computer. You can use the this feature to read aloud as much of an Adobe PDF document as you need: a
page, a section, or the entire document. Some systems may not
support this feature.

1. Navigate to page 1 of the Brochure.pdf file.

2. Choose View > Read Out Loud > Read This Page Only.

Notice that the Page does not read. Some PDF files cannot be read
until certain additional steps are performed.

Checking Accessibility

To check the accessibility of a PDF file:

1. Choose Advanced > Accessibility > Quick Check.

The following message is displayed:

This document cannot be read until tags are added to the
document. These tags tell the screen reader and other
assistive technology devices how to treat the text blocks,
paragraphs, etc.

2. Click OK.

3. Choose Advanced > Accessibility > Add Tags To Document.  Acrobat will evaluate the document and add
tags as needed.

4. Choose View > Navigation Tabs > Tags.

5. Click the Content Tab. You will see a list of tags that have been
added. These tags are necessary for screen reading devices to
operate properly.

Performing a Full Check of Accessibility

You can have Acrobat perform a full check and give you a report
based on the parameters you set. This can be a time-consuming
task on large documents. Pressing the Escape key can stop the
process.
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6. Choose Advanced > Accessibility > Full Check.

The Accessibility Full Check window opens.

Here you can set options for the amount of
detail you require in the report. We will leave
the settings alone for now.

7.  Click the Start Checking option. When checking is
complete a dialog box like the one to the right should
appear.

If there had been problems with the document, Acrobat
would have placed a HTML file report in your documents
folder listing the problems with your document and
providing hints for repair.

Reading Out Loud

Your PDF file is now ready for the Read-Out-Loud feature of Adobe Acrobat.

8. Choose View >  Read Out Loud >  Read This Page Only.

Your document will now begin to read in the proper reading order. (Be sure that your computer's sound is on so
that you can hear the reading.) Your PDF document is now accessible by almost everyone!

Enhancing Visibility

You can set various options to make it easier to see and read Adobe PDF documents on screen. You can:

•  Magnify the displayed document using the Viewing toolbar, the Zoom options on the status bar, or the
commands on the View menu.

•  Enlarge or reduce the font size of the bookmark text with the Options menu on the Bookmarks tab.
•  Set the background color of pages and the color of the text in the Preferences dialog box.
•  Replace document colors.
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To adjust the Accessibility options do this:

1. Open the saved Brochure.pdf document from the previous
exercise.

2. Choose Edit > Preferences and click on the Accessibility item
in the left side of the Preferences.

3. Choose the Replace Document Colors option and try a
different combination.

4. Click OK.
5. Open a PDF document and try out your changes.

➤ Be sure to use colors that improve visibility. These color
changes will not print but will be viewable onscreen.
These changes will affect all the PDF documents on
your computer.

Minimizing Mouse and Keyboard Usage

In order to reduce the amount of clicking and keyboard use for a PDF file, Acrobat allows you to set some
additional options.

Using Reflow

Once a PDF has been tagged properly, its contents can be reflowed to fit different screen sizes and document
areas. This will also enable you to reduce background colors and make
automatic scrolling more effective.

To reflow your Brochure.pdf file do this:

1. Click on the single page or continuous page icon at the bottom of
the document window.

2. Choose View > Reflow.
(If it is dimmed, you have not added the tags from the previous
activity).

The document will change its appearance and look like the picture to the
right.

3. Drag the lower-right corner of the document window to resize it.
Notice that the content reflows to fit the window size. This is because
the document contains the proper tags needed for accessibility.

Scrolling Automatically

The automatic scrolling feature makes it easier to scan through a long document. You can scroll through pages
without using keystrokes or mouse actions. To scroll automatically through a document do this:

4. Choose View > Automatically Scroll.

•  To change the scrolling speed, press a number key where 9 is the fastest and 0 is the slowest or press the Up
or Down arrow keys.

•  To reverse the direction of the scrolling, press the hyphen or minus sign key.
•  To jump to the next or previous page, press the Left or Right arrow keys.
•  To stop automatic scrolling, press the Escape key or choose View > Automatically Scroll again.
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Using Keyboard Shortcuts

You can control many menu commands and navigation functions from the keyboard. Acrobat 6.0 products
include more keyboard access features than did earlier Acrobat versions.

Note: In Windows®, some of the keyboard shortcuts used to navigate in Acrobat may differ from those used in
other Windows applications.

➤ Keyboard shortcuts are very powerful for all types of users. Shortcuts often vary for each platform and version of
the operating system. More information can be found in the Acrobat Help file.

Macintosh OS X users can navigate and interact within the Acrobat work area and Adobe PDF documents by
setting up the appropriate system-level preferences.

To set up full keyboard access on a Macintosh computer do this:

1. On the Apple menu, choose System Preferences, and select Keyboard.

2. In the Keyboard Preferences dialog box, select the Full Keyboard Access tab.

3. Select the Turn On Full Keyboard Access and Any Control.

4. Quit System Preferences.

Windows users can use the keyboard to control Acrobat within Microsoft® Internet Explorer.

•  Pressing the Tab key shifts the focus from the browser to the Acrobat document and application. The
navigation and command keystrokes will function normally.

•  Pressing Ctrl + Tab shifts the focus from the document back to Internet Explorer.
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Activities:

1. Investigate other information about Section 508 on the Web using one of the popular search engine Web
sites.

2. Have students check and convert existing PDF filess such as school information for accessibility.

3. Have students experiment with different screen enhancements and reading preferences for a particular
document  and have them present their different versions to the class.

4. Generate accessibility reports on PDF files from a variety of sources and discuss the different findings and
hints for improving accessibility.

5. Convert web pages to PDF using the techniques learned earlier. Notice that since web pages are already
tagged, many of them are already defined for accessibility.

6. If students have access to PDAs, have them load accessible PDF files onto their devices and report on the
appearance of their document compared to the original.

Additional Adobe Resources on the Web

Visit the Adobe in Education Web site at www.adobe.com/education for additional resources:

•  Instructional resources—free lessons, course guides, and projects that incorporate Adobe tools:
www.adobe.com/education/curriculum/main.html

•  Complete product information—Learn about Adobe’s complete line of integrated, award-winning products:
www.adobe.com/education/ed_products/main.html

•  Training opportunities—Build your Adobe software skills with free and discounted training resources:
www.adobe.com/education/educators/training/main.html

Important note: The Adobe Acrobat Curriculum Guide may only be used by certified educators and may only be used in the classroom.

Distribution of the Guide outside of the educator’s classroom or commercial use of the content of the Guide is prohibited. If you are

interested in using the Adobe Acrobat Curriculum Guide in any other way, please contact the author, Steve Adler at his Web site:

www.guidedsystems.com.
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